Welcome to SkydioPilots.com
Sign up and join the discussion!
Sign up

Skydio 2 New battery won't charge in drone


Sep 22, 2022
Reaction score
I have ordered a new Skydio 2 battery (not 2+). It came today but I'm not able to charge it. I don't have a dual charger so I'm trying to charge it in the drone with original cable and adapter.

It turns on for a few seconds just like with other working battery I have (drone LEDs are on). Then it blinks 5 times on a battery indicator (blue, 1/4) and then everything goes off. After 2 seconds, it turns on again, 5 blinks on battery and off. It keeps repeating it endlessly (for a 30 minutes now).

I tried to reset the battery as suggested in other threads but no luck.

What can I do?

Last edited:
i dont have a lot of battery knowledge but have you tried putting the battery on the drone without plugging in the charger and turning on the battery and letting it sit/drain until it is completely dead...and then try to recharge it?
The drone does not start on this battery. When not in charger, pressing the battery button results in the first battery led blinking and nothing happens.
After a few emails with Skydio support, they also think that the battery is defective and they asked me to throw it away 🤦‍♂️ They are about to send me another battery.

The suggestions from the support were similar to the ones you gave me, i.e.:
  1. The first thing to try is to reset the battery by pressing and holding the button on the battery for 10 seconds. You can do this while it's attached to the drone, and while using the power adapter to charge the battery through the drone. After that step, allow the battery to charge for one hour and note any LED activity.
  2. If you have a battery that doesn't seem to charge but has at least one blue LED when you press the battery button, please try discharging the battery slightly by attaching it to your drone and allowing it to power the drone on as it would normally for just a minute or so. Do not attach the charging cable and power adapter until it's had a minute or two to discharge slightly. Once discharged slightly, the battery should once again charge normally.
  • Like
Reactions: Ridefreak
Seems you have to do some strange connections sometimes to get the battery to start charging. This is what works for me. Plug in the BEACON to USB charger and turn it on. It will start looking for the drone. Attach a battery to the drone and power on. Hopefully you have at least 2-3% power to get the drone to communicate with the BEACON. Plug in the small wall charger that came with the drone and attach that charger via USB cable to the drone. The BEACON will find the drone and display how much battery power is remaining and start charging the battery. It's nice to be able to monitor the battery charge via the BEACON. The wall charger gets VERY hot when charging so keep it somewhere where there is good air circulation. You will also hear a hissing sound coming from the battery. That's a good sign that's it's accepting the charge. But as I mentioned, you can see the charging percentage via the BEACON. This has worked for ALL my batteries that were not charging via the dual charger.

Members online

No members online now.

Forum statistics

Latest member