Welcome to SkydioPilots.com
Sign up and join the discussion!
Sign up

Skydio doesn't always lock on me at launch

dmac1

Active member
Joined
Dec 7, 2020
Messages
43
Reaction score
13
I've been practicing and trying to refine my launch and recovery process so that I don't slow down a group ride.

Today, 3 times, when I launched S2 via beacon, with phone connected to beacon, the drone would turn around and look at me, but wouldn't get optical lock and upper right corner of beacon would say 'GPS' and cuz my phone's GPS was apparently inaccurate, it would fly away. Why no optical lock?? I'm simply standing in front of it with the beacon in my hand. It did that a few days ago at home in my yard....just flew away!

So, along the lines of incaccurate GPS, I'm using my old phone that has no cell connection. Does anyone know if a phone gets location from cell towers even if its not connected to that tower's network? I'd think the answer is no, but 911 works everywhere there is a cell tower no matter the carrier, so maybe it does get location no matter the network?

Thanks!
 

dmac1

Active member
Joined
Dec 7, 2020
Messages
43
Reaction score
13
Well, I tried the drone again today in my yard. Some of the same stuff, and some different. I think something has gone flakey in it...or in the beacon.

At the end of today, after multiple different issues, I launched it and it was locked on me optically, and I pushed it out to the 2nd position. It was there for a couple seconds and then my phone (which was connected to beacon) said weak signal. The drone was only 25' or so away! I was like, ok, so what, I was just gonna walk in my yard and the phones GPS signal is an issue for some reason cuz no wifi or cell signal. But then the drone totally lost connection with beacon and said 'land'. I switched beacon to steering. Tried to turn it and fly it, no response from drone. I walked over to where I was directly under it, tried to move it, nothing. Pushed stop and held it for land, 1,2, 3. Nothing, drone just hovering 4 or 5' over my head. I figured I'd hafta wait till battery was almost dead and it went into landing mode (and I was hoping it wouldn't fly off to some errant GPS coord cuz it was doing that too when it would lose me optically). Fortunately, somehow my repeated instructions to 'land' musta gotten through, cuz it did.

At one point, (earlier) it lost me when I was just walking and it said 'camera error' and 'land'. I could fly it via steering that time.

I dunno whats wrong, I don't even know if its the beacon or the drone. And yes, I tried restarting them both multiple times...thats all part of what I was doing...trying to get down a launch and recovery process that is as quick as possible and reliable...which is next to impossible when the drone is inconsistent in what it does.

Will advise if I ever get things figured out. Thought I'd try plugging the drone into my computer and seeing if there was an update or something like ya can do with DJI drones, but I don't think you can do that with S2.
 

Ridefreak

Well-known member
Wiki Editor
Joined
Nov 20, 2019
Messages
548
Reaction score
310
Well, I tried the drone again today in my yard. Some of the same stuff, and some different. I think something has gone flakey in it...or in the beacon.

At the end of today, after multiple different issues, I launched it and it was locked on me optically, and I pushed it out to the 2nd position. It was there for a couple seconds and then my phone (which was connected to beacon) said weak signal. The drone was only 25' or so away! I was like, ok, so what, I was just gonna walk in my yard and the phones GPS signal is an issue for some reason cuz no wifi or cell signal. But then the drone totally lost connection with beacon and said 'land'. I switched beacon to steering. Tried to turn it and fly it, no response from drone. I walked over to where I was directly under it, tried to move it, nothing. Pushed stop and held it for land, 1,2, 3. Nothing, drone just hovering 4 or 5' over my head. I figured I'd hafta wait till battery was almost dead and it went into landing mode (and I was hoping it wouldn't fly off to some errant GPS coord cuz it was doing that too when it would lose me optically). Fortunately, somehow my repeated instructions to 'land' musta gotten through, cuz it did.

At one point, (earlier) it lost me when I was just walking and it said 'camera error' and 'land'. I could fly it via steering that time.

I dunno whats wrong, I don't even know if its the beacon or the drone. And yes, I tried restarting them both multiple times...thats all part of what I was doing...trying to get down a launch and recovery process that is as quick as possible and reliable...which is next to impossible when the drone is inconsistent in what it does.

Will advise if I ever get things figured out. Thought I'd try plugging the drone into my computer and seeing if there was an update or something like ya can do with DJI drones, but I don't think you can do that with S2.
The app is what goes out and checks with Skydio's server to see if there's an update. It remembers the device's firmware versions and checks to see if there's an update. If it were mine I'd go out in a field away from anything and try to fly it with only the beacon. If that works try flying it with just the app. That might tell you if it's the phone, drone or beacon. I can loan you a beacon if that's the problem.
 

dmac1

Active member
Joined
Dec 7, 2020
Messages
43
Reaction score
13
The app is what goes out and checks with Skydio's server to see if there's an update. It remembers the device's firmware versions and checks to see if there's an update. If it were mine I'd go out in a field away from anything and try to fly it with only the beacon. If that works try flying it with just the app. That might tell you if it's the phone, drone or beacon. I can loan you a beacon if that's the problem.
Did what you suggested...fly with beacon then app separately. Does seem to be beacon related. Seems to fly ok with just app, but at walking pace, the drone's speed isn't steady. It falls behind, then catches up, then falls behind.

I kept a handwritten log (as best I could) while it went through its processes with beacon only and with beacon/app. The sequences vary, sometimes its pretty quick and sometimes it flies ok, but typically, beacon gets stuck in a sequence something like: 'syncing gps' (the slider moves forward, then backwards, then forwards, then jumps back, then says ready to fly, then looking for skydio, then syncing and slider back to the beginning, then it moves forwards and suddenly ready to fly. Its just not right.

Yesterday, after about 25 flights and while I was in basement, the app got an update and downloaded to drone. Tomorrow I will see if it gives the beacon an update.

Anyone have the drone just follow them via phone/app (ie no beacon)? I've always pretty much always used the beacon, but phone seems to work good.
 

Ridefreak

Well-known member
Wiki Editor
Joined
Nov 20, 2019
Messages
548
Reaction score
310
I've used the app to have follow me around walking, seemed normal. Range is very limited when it's doing that.

Mine is pretty consistent with it's initial subject lock. If you want to use my spare beacon shoot me an email, it might be tough to get them to resolve it before you head to Idaho.
 
  • Like
Reactions: dmac1

Latest threads

Members online

Forum statistics

Threads
915
Messages
7,024
Members
1,204
Latest member
Trobin007