Welcome to SkydioPilots.com
Sign up and join the discussion!
Sign up

Turn WiFi on or off when connecting controller?

Flynsign

New member
Joined
Sep 15, 2021
Messages
2
Reaction score
0
I go to fly the drone and when I turn everything on I get the following message on my iphone.… Connect Phone to Controller, Disable your phone‘s WIFI and connect to your Controller to launch. So I turn the WIFI off and connect it back up and then it immediately tells me to connect to the skydiowifi. I hit the connect button, then the join button, then it tells me I am connected. When I hit the done button it goes right back to the first message telling me to Disable the WIFI on phone and connect the controller. This just keeps repeating. What do I need to do at this point? The cable I’m using is the Mavic Air 2 cable (lightning to USB C).
 

dmac1

Well-known member
Joined
Dec 7, 2020
Messages
157
Reaction score
52
I wonder if its a cable issue. I'd ask skydio if what you are using (or is it what they sent you?) is compatible. I had to get a particular cable for my android. Its either that or maybe the controller's wifi isn't working,

The phone connection to the controller is via wire, so phone wifi not needed. The controller wifi connects to drone and thats how you fly the drone. I'd start with phone wifi off and plug it into the controller, then launch Skydio app. The message I get at that point is 'Controller connecting to drone, power on your drone'. Once I power on my drone, it connects, I get a message or 2, then Ready to Fly.

I get the same result whether phone's wifi is on or off....ie the phone's wifi isnt needed cuz it is wired to the controller and when my phone's wifi is on, its not connected to anything.

You could maybe try another phone, but doubtful that will change your result.
 

Saladshooter

Well-known member
Joined
Jun 13, 2021
Messages
152
Reaction score
103
I go to fly the drone and when I turn everything on I get the following message on my iphone.… Connect Phone to Controller, Disable your phone‘s WIFI and connect to your Controller to launch. So I turn the WIFI off and connect it back up and then it immediately tells me to connect to the skydiowifi. I hit the connect button, then the join button, then it tells me I am connected. When I hit the done button it goes right back to the first message telling me to Disable the WIFI on phone and connect the controller. This just keeps repeating. What do I need to do at this point? The cable I’m using is the Mavic Air 2 cable (lightning to USB C).
I have not been able to get any cable to work with the iPhone other than the overpriced $19 cable that Skydio sells. I assume its wired a bit differently as a data cable so it won't try to charge the phone and steal the controller's battery.
 

dmac1

Well-known member
Joined
Dec 7, 2020
Messages
157
Reaction score
52
My controller, which was part of a cinema upgrade kit, came with a lightning cable and usbc. Didnt they all?

I wasnt happy it didnt come with one for micro USB, but I didnt hesitate to buy one to make my controller work with the phone I wanted to use.
 
Last edited:

Romoacipiter

Member
Joined
Mar 13, 2022
Messages
9
Reaction score
0
Good afternoon, my name is Romo and I am from SPAIN. I bought the skydio 2+ in the USA and when trying to install it in Spain, neither the iPhone nor any device detects the wifi of the drone all the time, they give an error and the beacon says all the time that it is looking for it, I Tried to reset the drone, the Beacon application and everything is the same, can someone help me. Thank you very much
 

Saladshooter

Well-known member
Joined
Jun 13, 2021
Messages
152
Reaction score
103
Good afternoon, my name is Romo and I am from SPAIN. I bought the skydio 2+ in the USA and when trying to install it in Spain, neither the iPhone nor any device detects the wifi of the drone all the time, they give an error and the beacon says all the time that it is looking for it, I Tried to reset the drone, the Beacon application and everything is the same, can someone help me. Thank you very much

Try the fixes here:

NO WIFI SSID CONNECTION FOR EUROPE FIX FOR SKYDIO 2+
 

Romoacipiter

Member
Joined
Mar 13, 2022
Messages
9
Reaction score
0
Good evening from Spain, I have managed to link everything thanks to the explanations of my fellow forum members, I reset everything from the factory and when it was time to install it I took the drone down to the basement so that when it was turned on it would not detect the GPS and so I could track it I was even going to fly it but since it was night it wouldn't let me... the problem is that when you turn it off and on again the device detects the GPS again and the Wi-Fi disappears again, so I start over... SKYDIO will have to get an update now or return the money...
 

JoeydDetroit

Well-known member
Joined
Apr 4, 2021
Messages
68
Reaction score
13
I go to fly the drone and when I turn everything on I get the following message on my iphone.… Connect Phone to Controller, Disable your phone‘s WIFI and connect to your Controller to launch. So I turn the WIFI off and connect it back up and then it immediately tells me to connect to the skydiowifi. I hit the connect button, then the join button, then it tells me I am connected. When I hit the done button it goes right back to the first message telling me to Disable the WIFI on phone and connect the controller. This just keeps repeating. What do I need to do at this point? The cable I’m using is the Mavic Air 2 cable (lightning to USB C).
Welcome to the Android community. Oh wait You're an Iphone?! What same **** happening yo you guys too now!? WTF?
 

Ridefreak

Well-known member
Wiki Editor
Joined
Nov 20, 2019
Messages
839
Reaction score
556
Good evening from Spain, I have managed to link everything thanks to the explanations of my fellow forum members, I reset everything from the factory and when it was time to install it I took the drone down to the basement so that when it was turned on it would not detect the GPS and so I could track it I was even going to fly it but since it was night it wouldn't let me... the problem is that when you turn it off and on again the device detects the GPS again and the Wi-Fi disappears again, so I start over... SKYDIO will have to get an update now or return the money...
Turn off the auto login for the SkyDio Drone's network and keep it manual, when that screen comes up asking you to login it's trying to connect to the Skydio's WiFi, you don't want that to happen, the controller will automatically connect to the drone's wifi if it's been paired and you can look at the blue Led on the controller to watch that happen. When that login comes up and you're connected to the controller cancel the login, if the connection between the drone and controller has been established and the app is connected to the controller, hardwired you should be able to connect and control as long as you aren't affected by the wifi channel being used, there's some issues with that depending on the country, I'm pretty sure you'll have to select a different wifi channel if that's the case.
 
  • Like
Reactions: Downunderwonder

Latest threads

Members online

Forum statistics

Threads
1,262
Messages
10,458
Members
1,708
Latest member
Windjammer