Welcome to SkydioPilots.com
Sign up and join the discussion!
Sign up

Anyone else having trouble sending Skydio 2 footage to Mac.

MichaelH26

New member
Joined
Sep 1, 2020
Messages
2
Reaction score
1
Hello, I recently got my Skydio 2 and it has been incredible so far. My only problem is when I connect the usb cable to my MacBook to upload the footage I end up with about half of the video with no sound on photos/Imovie. I can see the footage WITH sound when I view through the App on my iPhone. Is this just a Mac thing? Do I need a better editing program? I am new to this and any help would be appreciated. Thanks
 
  • Like
Reactions: Lifeisfun

skydioconvert

Well-known member
Joined
Dec 15, 2019
Messages
805
Reaction score
164
Don't know if this helps but the reviewer in the attached video touches on some oddities of the S2 when it comes to its audio recordings.

 

Lifeisfun

Well-known member
Joined
Dec 27, 2019
Messages
426
Reaction score
106
Hello, I recently got my Skydio 2 and it has been incredible so far. My only problem is when I connect the usb cable to my MacBook to upload the footage I end up with about half of the video with no sound on photos/Imovie. I can see the footage WITH sound when I view through the App on my iPhone. Is this just a Mac thing? Do I need a better editing program? I am new to this and any help would be appreciated. Thanks
For now, get used to it, known problem, if you reset the drone it will start working again and 3 flights later it will usually not save the audio again. The audio file is simply missing on the SD card.:( Reported to Skydio, only solution they found is to reset the drone.
Could be helpful if you upload your logs Skydio and report it.
Make sure all devices (beacon or controller) you used for the particular flight are connected when creating the log.
 
Last edited:

VEGASROBBI

Well-known member
Joined
Oct 26, 2019
Messages
308
Reaction score
182
I thought this was odd, I don't use the audio from the Skydio SD card. The other day put the SD card in my PC as usual and saw the MP4 files. There were no audio files showing. I didn't have time to download the files so I put the SD card back in my S2, did a couple more flights and when I put the SD card back into my PC the audio files showed up for the first flights.
 

Lifeisfun

Well-known member
Joined
Dec 27, 2019
Messages
426
Reaction score
106
I thought this was odd, I don't use the audio from the Skydio SD card. The other day put the SD card in my PC as usual and saw the MP4 files. There were no audio files showing. I didn't have time to download the files so I put the SD card back in my S2, did a couple more flights and when I put the SD card back into my PC the audio files showed up for the first flights.
Yeah, it's spotty, and inconsistent, perhaps that's why is so hard to find the problem.
I'll try not to wipe the card next time if it will act the same.
 

ag2prcntr

New member
Joined
Jan 18, 2021
Messages
2
Reaction score
0
Just wanted to see if you ever got this resolved. I got my S2 a couple of days ago. Any video longer than 5 minutes 20 seconds freezes up when I download it to my Mac into the Photos app. This is consistent, from the app I can watch the whole video. Let me know if you ever got this resolved. So frustrating...
 

MichaelH26

New member
Joined
Sep 1, 2020
Messages
2
Reaction score
1
I found that if I removed the sd card from the skydio and loaded the footage to my Macbook with an sd card reader I no longer had issues. I then use Imovie to edit the footage. I haven’t used the photos app much except for watching short clips I saved from the S2 app and sent to my IPhone/Macbook. For some reason when I connected directly to the MacBook from the S2 the video and especially the audio were corrupted. I would have to power off and on the S2 and try several times before the whole video would load without freezing after 5 minutes or missing audio.
 

ag2prcntr

New member
Joined
Jan 18, 2021
Messages
2
Reaction score
0
I found that if I removed the sd card from the skydio and loaded the footage to my Macbook with an sd card reader I no longer had issues. I then use Imovie to edit the footage. I haven’t used the photos app much except for watching short clips I saved from the S2 app and sent to my IPhone/Macbook. For some reason when I connected directly to the MacBook from the S2 the video and especially the audio were corrupted. I would have to power off and on the S2 and try several times before the whole video would load without freezing after 5 minutes or missing audio.
I can't get the SD card out, it's seated in there pretty good and no matter how hard I push on the card to have it eject it just kind of "squishes" in there. Feel like I'm going to break the card.
 

YahMonMan

New member
Joined
Feb 16, 2021
Messages
4
Reaction score
2
I was having this problem a lot as well but think I have it figured out. I don’t believe it is a Mac or a drone problem. Remember: the video is recorded on the S2, the audio is recorded on the phone. Once the S2 has landed, your phone THEN starts uploading the audio file to the S2. This takes a little time, longer for the longer flights. If you power-down your Skydio2 too soon after the flight there will not be enough time & kinda screws up the transfer & maybe even damages the audio file? To be sure all is good, directly after the flight try viewing at least just the beginning of the file in the Media Browser in the app- it won’t start playback until the audio is transferred & sync’d. Otherwise, you can actually find the copies of the audio files on the phone by connecting your phone to iTunes, selecting your phone & going to the “File Sharing” tab, and then select the Skydio 2 App. Select the “com.skydio” folder & then click “save.” Your audio files are in there.... as well as the flight logs & everything else. You can then use QuickTime to add the audio to the video manually. (Sounds way more complicated than it is.)
 

Latest threads

Members online

Forum statistics

Threads
817
Messages
6,418
Members
1,053
Latest member
Howie121218