Welcome to SkydioPilots.com
Sign up and join the discussion!
Sign up

Controller Charging Issue

dmac1

Well-known member
Joined
Dec 7, 2020
Messages
70
Reaction score
23
I got my S2 in November and have only tried to charge the controller twice. If you saw my post from before, you know why (no micro USB/USB C cable). I got that resolved, but the green led has never came on and its been on the charger for hours. The controller works, flew with it yesterday, but I don't have a ton of confidence in its longevity. I'm assuming its defective, but wondering if others have experienced the same issue?
 
  • Like
Reactions: Milebyro

dmac1

Well-known member
Joined
Dec 7, 2020
Messages
70
Reaction score
23
Just an update in case anyone is interested. I sent a message to Skydio and have had some dialogue with one of their representatives. He was going to get with their engineers because he had me connect my drone/phone/controller and look on the Fly tab under Controller at what it says for charge percentage.

Mine doesn't give a percentage. It says RC7.0.23...and the order of the 3 items are Drone Phone Controller, whereas the Controller Manual, under App, shows Drone Controller Phone. The latter might be meaningless, but its different from what the manual says.

Also, I discovered that the LED actually does turn green eventually. Its sooo faint, I thought the controller had turned off/timed out or something. I hafta cup my hand around it to create a dark shadow within which to see that the LED is actually green, and this is inside my house.

Lastly, once the LED had turned green, I reconnected drone/phone/controller to check again on charge percentage. The controller was on for 1 minute max, and actually prolly closer to 45 seconds. Same result (RC7.0.23) but heres why I mention this. I reconnected controller to charger and 2 hours later, the LED was still red. Thats after less than 1 minute of use.

Something is not right. The Rep and I think the controller is defective, but the absence of it showing charge percentage has him stumped. I didn't hear from them yesterday tho. Will advise what I learn.
 
  • Like
Reactions: Milebyro

dmac1

Well-known member
Joined
Dec 7, 2020
Messages
70
Reaction score
23
Tried again yesterday and used my wife's phone. Its a Galaxy Note 5 running Android version 7. My phone is Galaxy S6 also on Android version 7. Anyway, her phone showed exact same RC7.0.23 instead of controller charge %. And, after controller simply sat unused for 3 days (after 2+ hours of charging that got no green LED) it took about 3 1/4 hours of connection to charger to get the super faint green LED on controller. I asked yesterday for a new controller, which I think is the problem. The charger charges the batteries ok. I'm using the cable they provided for charging.

The problem is either: Controller, App, Android 7 or the MicroUSB/USB C cable I'm using to connect phone to controller. Weeks ago I asked Skydio which cable to get and I bought what they said they use for Micro to USB C. Frankly, I think they should provide said cable...they provide the others, why not this one?

No word from Skydio engineers that I know of....did hear from Rep yesterday asking if I've flown via controller since we last talked. Answer No. It was my idea to try wife's phone.

More when I know more
 

dmac1

Well-known member
Joined
Dec 7, 2020
Messages
70
Reaction score
23
Controller shipped off yesterday to Skydio for replacement.
 

Latest threads

Members online

No members online now.

Forum statistics

Threads
966
Messages
7,452
Members
1,307
Latest member
SLYDWAYS