Welcome to SkydioPilots.com
Sign up and join the discussion!
Sign up

Dual battery charger refuses to fully-charge sometimes (batteries stuck in discharge mode?)

scrampker

Well-known member
Joined
Oct 27, 2020
Messages
60
Reaction score
11
I'm seeing randomly when some of my batteries go into discharge mode, simply throwing them on the dual charger before I go out doesn't work. It's happened about 3 times in the last few months, and I have to put the battery in the drone and charge it that way. Pretty annoying. AFAIK I have the lastest update on the charger, which required plugging it into the drone, and watching the colors change.

When the batteries fail to charge, the light up for a moment when placed in the charger, (showing 50% or whatever,) then it just turns back off. Using stock wall wart, cable, etc. Odd behavior.
 

Ridefreak

Well-known member
Wiki Editor
Joined
Nov 20, 2019
Messages
449
Reaction score
236
I've noticed that sometimes one of the batteries won't fully charge (only up to 3 bars) on the charger but will top off when charged through the drone. Doesn't always do that, just occasionally. I usually run them all the way down (1 bar) when flying and it's never an issue then, only when they've been sitting and done the auto 50% discharge after sitting 2 weeks. Something I'd try if I were you is power up the drone in the house on the battery in question, let it sit there powered up or fly it so it discharges some and try charging it again. It seems to be a quirk but so far it's been easy to overcome for me.
 
Last edited:

Skyking

Well-known member
Joined
Jan 4, 2020
Messages
69
Reaction score
20
I'm seeing randomly when some of my batteries go into discharge mode, simply throwing them on the dual charger before I go out doesn't work. It's happened about 3 times in the last few months, and I have to put the battery in the drone and charge it that way. Pretty annoying. AFAIK I have the lastest update on the charger, which required plugging it into the drone, and watching the colors change.

When the batteries fail to charge, the light up for a moment when placed in the charger, (showing 50% or whatever,) then it just turns back off. Using stock wall wart, cable, etc. Odd behavior.
I had batter luck using 100 watt type C chargers
 
  • Like
Reactions: richinAZ

DrKnome

New member
Joined
Dec 30, 2020
Messages
2
Reaction score
0
I have this problem too. Repeatedly. A battery will self-discharge to the 60% state. Put it in the charger accesory and it will charge a little then stop, staying at that level. I thought the battery was defective and labeled it. This morning (a few weeks) later that battery charged fine and another battery did the same thing.
 

scrampker

Well-known member
Joined
Oct 27, 2020
Messages
60
Reaction score
11
I have this problem too. Repeatedly. A battery will self-discharge to the 60% state. Put it in the charger accesory and it will charge a little then stop, staying at that level. I thought the battery was defective and labeled it. This morning (a few weeks) later that battery charged fine and another battery did the same thing.
Yeah I'm seeing this more and more.

I'm starting to think I should only use two of my 4 batteries regularly, then if something big comes up, charge the other two as well.

This whole discharge thing is a disaster. Ironically they are causing more damage by creating extra cycles. I'd guestimate that about 80% of my battery cycles overall have been self-discharge. Kind of dumb. My other lithium devices don't do this and the batteries still last for years. Only reason this would make sense is if they were attempting to over-charge these cells, so they need to drain back down to prevent explosions.
 

Latest threads

Members online

No members online now.

Forum statistics

Threads
688
Messages
5,568
Members
840
Latest member
Cronos01