Welcome to SkydioPilots.com
Sign up and join the discussion!
Sign up

Skydio 2+ (not S2) hardware reset sequence

singular.droid

Well-known member
Joined
Dec 3, 2020
Messages
62
Reaction score
25
Hi everyone,

Got a S2+ drone which has been in light accident. No scratches or anything visually from the outside, however upon drone on it is loading (blue light is blinking from dim to bright a bit, like in normal load) then it stays constantly blue and bright, there is no wifi connectivity broadcast whatsoever. I'm going to do hard reset and question - is the procedure any different for S2+ comparing to S2?
 

BlueHeeler

Well-known member
Joined
Apr 20, 2021
Messages
67
Reaction score
30
Location
Southern New Jersey
I have both the S2 and S2+, identical procedures for everything for Software, IDK what a Hardware Re-Set is .

Not sure what you're experiencing, but I will try my best not to confuse you.

Check to make sure your Device recognizes the drone, also sometimes devices don't automatically switch from your Wifi router ( Downloading from the App ) ) to the Wifi of the Drone ( uploading from Device ) even after following the Prompts, kinda like being caught in a loop.

Note : I always turn off for 10 seconds and power back up my Mini Ipad and Drone to Re-boot AFTER any updating is complete.

Hope this helps a bit.
 
Last edited:

singular.droid

Well-known member
Joined
Dec 3, 2020
Messages
62
Reaction score
25
I see that the boot procedure is as usual, but there is no wifi network at all. this happened after minor crash with zero physical damage. As I can understand and remember after correct startup gimbal becomes leveled and now it is not happening - gimbal is free and could be rotated by finger without any force. I also tried to connect new beacon over the usb to the drone to make them sync, but it didnt happen, beacon is charging but is not syncing, if I disconnect beacon it search for the previously synchronized drone (not the one I'm getting problem with).

I tried reboot sequence like:
1. dismount battery from drone
2. connect drone to usb charger and wait 2 blinks of blue, then disconnect usb power. do this 6 times and then leave drone connected to usb power for 20 minutes - nothing has happened, it didn't reboot or restored any backup, no significant light sequence (only blue light was solid).
3. I also tried same as above but wait each time for 6 blinks of blue then disconnect usb outlet and also 6 times in a row. same effect - no hardware reset.
just a question on procedure - on 7th time, should drone be connected to usb and ALSO has a battery attached or it will reset with only usb power source attached?
 

BlueHeeler

Well-known member
Joined
Apr 20, 2021
Messages
67
Reaction score
30
Location
Southern New Jersey
Darn, you have more patience than I do, sorry to hear no success in getting this to work properly, sounds like your S2+ needs a full Diagnostic and Repair, but at what cost ?
As for your question, should the battery be connected to the S2+ during resets, probably yes. I have always had the battery attached during firmware updates and system resets, I have never tried using the USB cable alone..
 

Latest threads

Members online

No members online now.

Forum statistics

Threads
1,413
Messages
11,404
Members
1,980
Latest member
Hi8uS