Welcome to SkydioPilots.com
Sign up and join the discussion!
Sign up

Help, Was doing SW update and my Beacon died!

Brentbat

Member
Joined
Jan 30, 2021
Messages
16
Reaction score
9
I got the new update for Skydio2 yesterday. App Version 15.10.0

I downloaded the update for the drone and performed the update... no problems.

Then I connected with the beacon and it sent the software update to the beacon... I watched the progress. It got to 100%, then it looked like it was rebooting the beacon.... then NOTHING! The beacon didn't reboot it just stayed off.

I can't get the beacon to show any signs of life. It was fully charged before I did the update, I've tried holding several key combinations for about 6 seconds trying to see if there was some sort of "hard reboot".... but so far... Nothing!

Does anybody have any experience bringing a beacon back to life?

Thanks in advance
Brent
 

funonfly

Well-known member
Joined
Apr 8, 2020
Messages
99
Reaction score
18
Website
www.youtube.com
I got the new update for Skydio2 yesterday. App Version 15.10.0

I downloaded the update for the drone and performed the update... no problems.

Then I connected with the beacon and it sent the software update to the beacon... I watched the progress. It got to 100%, then it looked like it was rebooting the beacon.... then NOTHING! The beacon didn't reboot it just stayed off.

I can't get the beacon to show any signs of life. It was fully charged before I did the update, I've tried holding several key combinations for about 6 seconds trying to see if there was some sort of "hard reboot".... but so far... Nothing!

Does anybody have any experience bringing a beacon back to life?

Thanks in advance
Brent
Did you try connecting the beacon with the usb c - usb c to the drone ?
 

Brentbat

Member
Joined
Jan 30, 2021
Messages
16
Reaction score
9
No, I haven'
Did you try connecting the beacon with the usb c - usb c to the drone ?
No, I haven't tried connecting to the drone with the USB cable, I'll try that, but I'm not overly optimistic, there is literally NO sign of life with the beacon at all. But I'll give everything a shot.
 

VEGASROBBI

Well-known member
Joined
Oct 26, 2019
Messages
371
Reaction score
215
This happened during my update. As stated above I plugged in the short USB-C to USB-C cable (supplied) between my S2 and Beacon and they paired. It took about 40 seconds to pair but my Beacon is working again.
 

Brentbat

Member
Joined
Jan 30, 2021
Messages
16
Reaction score
9
Hey there
This happened during my update. As stated above I plugged in the short USB-C to USB-C cable (supplied) between my S2 and Beacon and they paired. It took about 40 seconds to pair but my Beacon is working again.
Hey there VegasRobbi

Success!!!! Your suggestion worked. I had tried charging the beacon from a USB C charger, but no joy.

Once I plugged it into the Skydio2 it lit up immediately and said it was charging. What is strange is that I had my beacon fully charged before I began the update.... when it went to reboot the beacon, it died.

When I plugged it into the Skydio2 it said "Charging", but it was at Zero% charge. So it was like the update zapped every bit of juice out of the beacon..... but only the Skydio2 could bring it back to life.

Anyway, I have now charged my beacon, done a test flight and all is well in Skydio2 land again.

Relieved.... Incidentally I logged a ticket with Skydio at the same time I posted to this forum (exactly a week ago), and I still haven't heard a peep out of Skydio Support. They suck!
 

Latest threads

Members online

Forum statistics

Threads
966
Messages
7,452
Members
1,307
Latest member
SLYDWAYS